Helicopter moves ha...
 
Notifications
Clear all

Helicopter moves hard to left when Auto-level check in Setup-2 or Setup-3

8 Posts
2 Users
1 Reactions
228 Views
(@keith-joneses)
Active Member Customer
Joined: 9 months ago
Posts: 7
Topic starter  

I've been fighting this battle ever since I got the Brain-2.  When I go into Setup-2 or Setup-3 with Auto-Level block checked, the helicopter normally goes sideways to the left, hard.  Sometimes it goes left and back.   

To add to this problem, the last two times I've tried it after the update, about three minutes into a hover, the helicopter tried to go inverted all on its own. That didn't work when it was only two feet off the ground.  I purchased this for the Auto-Level and Recue feature and all it has done is caused problems. I have not had enough faith in it to fly the helicopter yet.

One other thing, I'm told it's supposed to give four pumps on the cyclic, this one has always just given two pumps.  Is that normal for it?  

I've been testing it on my desk without blades or tail on it, just running the motor and drive gear and watching how the servo arms move when I go to setup-2.   I have found that if I have the helicopter setting at the three-degree angle to the right (looking from the tail) and the nose down two-degrees, when I plug the battery in and let it initialize, like that, the servo arms don't move when I go into setup-2, even if I take it off the leveling base I had it on.

The Last two logs 25 and 28 are two I just did on the desk.  25 was with the helicopter initialized level on the desk and 28 with the helicopter setting at 3 degrees right and two degrees down on the nose when it was initialized.

I had sent in a question about it three weeks ago, " MSH Brain 2 AutoLevel question"  but didn't see it and have been working on the problem since, until I've finally given up when I went inverted on me with no input on my part, I'm pretty sure log 12 was on it did that on, it didn't record the first one because I had just done the update and didn't go back and tell it to record logs.'


   
Quote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1123
 

The initial premise is that, when active, Auto Level cannot tilt the model more than 45°, nor can the pilot do so intentionally via the sticks. This maximum tilt is controlled by gyroscopes, which unlike accelerometers do not suffer from external influences such as vibrations that accelerometers can suffer from.
Therefore, if the model activating Auto Level even rotates 180 degrees by flipping over it means that there are errors in the flight controller setup.

From checking the configuration file you sent us, we see on page 1 of the Wizard that for your model you have set it as "Unlisted":
The motor
THE ESC
The cyclic servos
The main blades
Can you tell us what brands and models you use so we can add them in the next release?
Thanks

The position of the flight controller on the model set in panel 2 of the Wizard seems to be wrong / reversed because the Z (vertical) accelerometer instead of reading +1G earth gravity acceleration reads -1G.
Can you send us a picture from which we can see how the flight controller is mounted on the model?

In panel 3 of the Wizard you have set only one DSM2 satellite (now obsolete and out of market) with 22ms frame rate and only 7 channels.
It would be better to use a DSMX satellite if you have it.
However, we suggest that you set your DSM2 satellite to 11ms and re-bind with the transmitter so that you have twice as many command updates in the same time in addition to the eleven radio channels.
The 22ms protocol is only there to be used on very old RTF models not capable of 11ms operation.
Perhaps your satellite is not original Spektrum but a "compatible" (Orange, Lemon, etc.)?

Not having followed what is written in the message that appears before saving the configuration file:

immagine

we are unfortunately not able to know if in your transmitter the reverses and ATVs of the channels have been adjusted correctly, and this is a fundamental question for the correct functioning of the Auto Level.

In panel 11 you have not set any flight style for any of the three Flight Parameter Setups.

Since we do not know which ESC model you are using (see panel 1) we are unable to know if the MIN and MAX values for Throttle Out are correct.

The first activation of your flight controller appears to have been made Monday, September 11, 2023 11:14:31 PM
But the flight counter, shows already made 136 flights for a total duration of 5 hours, 14 minutes and 14 seconds.
Do you find that in a month and a half (45 days) you have already made that many flights (3 flights a day every day for an average duration of 2 1/2 minutes each)?
Or are a large portion of them bench tests performed with the engine running for more than 10 seconds (hopefully without main and tail blades)?

In the logs sent to us, the RPMs do not appear to be recorded.
This is strange because by now all ESCs (except Kontronik) have a special output lead that carries the motor rotation pulses that you just plug into the GOV port of the flight controller. Then again, since you did not indicate in panel 1 the brand of your ESC we do not know which one it is and it might even be a Kontronik.

In the logs we notice strange positive spikes in the voltage feeding servos and flight controller. Since you have not indicated the brand of the ESC (panel1) we do not know what characteristics your ESC's BEC might have and why it is behaving this way.
It could be the servo motors generating a reverse EMF when they decelerate (dynamo effect) but we also don't know what brand and models of servos you are using for the cyclic (panel1).

immagine

Related to your last two questions:

During initialization the swashplate goes to zero pitch. At the end of initialization from zero pitch it goes to positive pitch, then goes to negative pitch, then back to positive pitch, and finally back to negative pitch (if the pitch stick is at zero).
So, the answer is yes: relative to its center position, the swashplate makes four movements at the end of initialization.
However, it may be four Aileron movements or four Elevator movements instead, which in this case indicate problems at power-up as explained in panel 14 of the Wizard.

You started the thread "MSH Brain2 AutoLevel question" on October 2 with a question and we from the very beginning told you that, as it says everywhere on our site, you should send us the necessary files to enable us to try to do a remote diagnosis. Files, however, that you never wanted to send us otherwise we could have given you all the answers exactly as we have done now in this new thread. However, as you can see in the thread we still gave you the specific information you asked for (you could have continued in the old thread without opening a new one. At this point we are closing the previous thread because it is clear that it will have no further follow up). We do not understand why you now write that we had not responded to you.


   
ReplyQuote
(@keith-joneses)
Active Member Customer
Joined: 9 months ago
Posts: 7
Topic starter  

I apologize if I made it sound like I was saying you didn’t respond to the first time I asked a question.  I didn’t say you did not respond, I said I didn’t see the post and figured it had been deleted.  That’s why I started a new post. Had I seen that one, I would have just responded on it.  I thought it was ended when you said you would need all the data I’ve just sent, since I was just asking a question in the first post.  I thought I told you I would try to gather it and make a formal tech support request, which is what I’m doing now.

As for the Log count, I have been working on this thing steady for since I received it on Sept 11 from Amain Hobbies.   I’m sure I have over 100 hours of just working on this one helicopter trying to get this Brain 2 to work properly.  To this day, I have not actually flown the helicopter because I have not trusted it enough to fly it.  As for Logs, yes there are a large number of just being on the bench logs but I’m sure I have close to 100 test just hovering it.  It has been the direct cause of breaking five sets of blades, bending four main shafts and four feathering shaft, and one tail boom and torque tube from a blade striking them.  They have all been minor as far as crashes go.  If it goes over sideways just enough for the blade to touch something, it’s going to damage the blade and bend those shafts.

The helicopter going inverted on its own is new and has just recently happened, and has nothing to do with the Auto-Level problem.  The first time it did it, I was about three minutes into a test hover in Setup-2 with Auto-Level activated.  This was the first test I had done since doing the new program update and I didn’t get the log on that one.  Thinking the Auto-Level was the problem, after repairing it, I did a second hovering test and stayed in Setup-1 without Auto-Level or Rescue and about three minutes in, it did that same inverted roll to the right  it did the first time.  I’m pretty sure that was Log 12.  When Auto-Level is activated, it moves sideways to the left.  When it tried to go inverted, it rolled to the right.

I did the TX with both sticks down and to the right for the configuration as your guide said do.  That must not work on my radio.  My radio is the old JR X9303 DSM2 that was purchased in about 2007.  It does not have a lot of the channel swapping functions the new radios have.  It took me two weeks to finally get the Brain 2 programmed into it so everything worked. 

I first tried an older DSMX satellite receiver for a couple of weeks so I would have all eight channels but kept getting numerous RX signal loses and going into failsafe with it.  Thinking maybe it was faulty; I ordered a new one from Horizon Hobbies just to be sure I didn’t get on of the Chinese clones.  It did the same thing.   I tried both together on it and it still gave too many RX signal loses.  Since Horizon Hobbies does not sell your items and they no longer support my radio, they would not even talk to me about the signal loses.

The seven channel DSM2 receivers I have and the satellites are all authentic Spectrum DSM2 receivers, and yes they are also as old as the radio.   I’ve tried to bind them at the 11ms speed and they wouldn’t bind or work.  I have a nine channel DSM2 in my Trex 600N that came with the radio when I purchased it so it’s still the same age as these 7 channel ones.

I’m on the third motor.  The first was an Align 3700KV.  It was about 10 years old and broke the shaft, common thing for those motors.  The second motor was a Scorpion HK-2221-8.  A bearing went out in it and screwed it up.  The third is a generic F2836 4000KV I have just recently installed it and these test I’ve been recently doing are the first ones done with this motor.   I have has this same problem with all of them. 

I have double checked and triple checked the orientation and it’s right.  Bottom up wires to the front, I even verified it again to make sure the new program update didn’t change it.

The Cyclic servos were Hitec HS65 for most of the time.  About 10 days ago I swapped them out for some generic digitals EMAXES09MD.  The Tail servos is the Futaba 9257. 

The ESC was a Hobbywing  40A Skywalker V2.  It failed and returned it to Hobbywing.  I upgraded that one I’ve just received a Hobbywing Platinum 60A and the Programmer for it.  For the past week, I’ve been using a generic 40A ESC from Amazon but the Hobbywing Platimum yesterday afternoon.  I have been doing test with it this morning.  None of the ESC I’ve had prior to getting this platinum had the capability for data recording, governor or anything else other than ESC/BEC.  I still need to set it up in page 12 of the wizard.  Those voltage spikes have been there with every ESC/BEC I’ve tried when the servos are moving.   I noticed this neew Platinum was giving spikes to near 6VDC and I had to turn it all the way down to 5.0VDC because my tail servos is only 4.8VDC and 5.5 is about the max I want to see on it.

The blades are generic fiberglass that cost about $8 a pair.  After a couple of sets of the good CF blades, I couldn’t afford to keep breaking those.

The transmitter setup on page 5 of the Wizard shows everything centered and moving to the endpoints as it should be

Governor logs, this Platinum ESC is the first one that has had that capability and to be honest, I’m not sure how to set that up yet.  I don’t know if I need a censored motor and not real sure where I want the RPMs yet.  Either way, I’m really not wanting to mess with setting it up.  I have enough complications now, I just don’t care to add anymore at the moment, and it seems everything I touch with this stuff since getting back into it, turns to shit.

I did the bind on the RX in the DSMX mode.  I also swapped out the satellite cable for a new one just to make sure that was not a problem

I tried the config download again after doing that, to see if it works this time.

I have run several tests with the Hobbywing Platinum 60A ESC.  I unplugged the tail servo and tried it at 6.0VDC, that didn’t make any difference.  I had to set it back to 5.0VDC because it was still spiking at close to 6VDC when I tried it at 5.2VDC and that’s too much for my 4.8VDC tail servo

I had to get out of this hobby for almost eight years because of medical problems and just now getting back into it, and trying to do it with what I had from back then because I’m not sure I’m going to be able to do it now, so I’m trying to limit what it cost me the best I can.  I thought this Brain 2 with Auto-Level and Rescue would save me some crashes, but I think we are way beyond that now.

Forgot the latest EVENTS log. 

I added a short video of what it does going in and out of Set-Up-2 with Auto level activated.  The bouncing around is me holding the cameral while switching the radio.  

 

Brain2
RX
Radio

 


   
ReplyQuote
(@keith-joneses)
Active Member Customer
Joined: 9 months ago
Posts: 7
Topic starter  

Posted by: @customercare

The position of the flight controller on the model set in panel 2 of the Wizard seems to be wrong / reversed because the Z (vertical) accelerometer instead of reading +1G earth gravity acceleration reads -1G.

Can you at least tell me what I'm supposed to do about that.  As you can see from the picture, the flight controller is physically mounted as it is in the manner it's says in the panel 2 of the Wizard.  It seems apparently the flight controller is defective and has been since day one of receiving it.


   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1123
 

Thank you for the wealth of information, the thorough description of the problem, and the new files and images.

In your case, trying to give you as complete an answer as possible required more time than usual.

Strong vibrations are always the greatest and most probable cause of errors in correctly reading the direction of Earth's gravity acceleration. With the first two engines it was certainly the main cause of lateral drift.
Of the previous logs checking the last two logs with the new firmware 3.4.139 the vibrations seemed good and within tolerable limits.

On the other hand, regarding the video, with the model resting without plastic skids on the table and the motor running, it is very likely that the vibrations have risen beyond acceptable limits. You should see the vibrations in the real-time graphs. This situation does not correspond at all to when the model is in flight and free in the air also the gyroscopes are not able to see any model tilt generated by servo movements and therefore do not compensate for it but even accentuate it.

Small note regarding the cyclic servos: The HiTech HS65 are very popular servos and are already on our servo lists:

immagine

On the other hand, looking on the net for the specifications of the EMAXES09MD servos, the manufacturer does not state in its specifications that they can go up to 333Hz. So if you notice that the servos after running a few minutes get hot, we suggest that you set a lower refresh rate (e.g. 165Hz) in panel 7 for these new cyclic servos of yours.

From what you have written it seems that one of the problems is caused by incorrect signals received from the transmitter.

Since you say that you have been out of the hobby for 8 years, if you have not already done so, we strongly suggest that you replace the battery pack of your transmitter because it is highly likely that by leaving the battery pack (it is probably still a NiCd NiMh pack) unused for so many years, due to normal self-discharge one or more cells have become damaged and now when you charge the battery pack it appears to be charging but as soon as current is drawn the battery voltage may drop considerably if not even to zero while you are in flight.

Also, we do not have your transmitter model, so we do not know if it is possible to set values for various channels in case of Fail Safe. It could be that when the transmitter sees that there is a strong reduction in the connection with the satellites (Fades value and/or RSSI value received from the satellites), it transmits values set as Fail Safe.
Instead, Fail Safe on RC Heli should always be set to Hold mode (holding the last valid position).

From the traffic lights in Panel 5 (only one green for SAT1) and Events (only the "Satellite 1 Connected" event is present), it appears that it uses only one satellite.
Two satellites must be used for Spektrum's Diversity function to work.
If you have a second satellite we suggest that you connect it and place the two satellites on the model with the antennas protruding outside the carbon frame (shielding being in conductive carbon) and with the antennas of the two satellites placed orthogonal to each other so that in whatever position the model is in with respect to the transmitter when the antenna of one satellite is shielded by the carbon frame and no longer visible from the transmitter the antenna of the other satellite is visible.

In the new configuration file we see that compared to the previous configuration you have changed satellite type selection from "DSM2 1024" to "DSM2 2048" (as by the way is clearly written above the screen of your transmitter in the picture you posted).
The consequence is that now in the new Recorded Logs you sent us we no longer see the value of the Frame Rate curve rise (which indicates loss of frames of the radio channels) as we saw before:

immagine
immagine
immagine

but now in the new logs the Frame Rates curve is clean and consistently on the 11ms value (time between one valid frame and the next valid frame).
So there is a significant improvement over the previous logs above that seems to depend on selecting the correct protocol used by the transmitter.

The negative Earth gravity acceleration value problem also seems to be solved.

In the new configuration file we still continue to see that you have no flight style set in panel 11.
Do not fly without a flight style set because the flight controller would not know how it should behave.

We see that in panel 13 you have activated the Auto Level checkbox for the B-Aux1 channel but in panel 5 we see that the B-Aux1 channel is not at -100% but at 0 which is an intermediate position and that for the flight controller results in an undefined value between the two values of Off (-100%) and On (+100%). You should correct in the transmitter the radio channel signal used for the B-Aux1 function by bringing it to work only between -100% and +100%.
Otherwise since you already use The Auto Level in Setup 2 and Setup 3, disable it from the B-Aux1 channel.

In the new setup file that you saved this time holding the sticks down and to the right we see that the collective pitch turns out to be at -12%. So confirm you are NOT using a linear collective pitch curve that goes from -100% to +100% but are using a typical curve for "Scale" models?
Are you sure the curve is always the same and never changes going from Normal to IdleUp1 and IdleUp2? And the pitch curve never changes either by going from Setup1 to Setup2 and to Setup3?

Are you sure and have you verified on transmitter servo monitor that the Aileron and Elevator trims are always at zero going from Normal to IdleUp1 and IdleUp2? And that they always remain at zero even when going from Setup1 to Setup2 and to Setup3? Normally in transmitters it is possible to completely disable trim operation. If your transmitter also allows this, we strongly suggest that you turn them off so that you cannot star them even inadvertently.

Although you said that you are using the new Platinum 60A, (you did not specify whether it is model V3 or V4) in the new setup file we notice that in panel 12 you have not yet set the two Throttle Out values MIN=1100 and MAX=1940 suggested by Hobbywing in all its ESC instructions:

immagine

Also in the new configuration file, we notice that you have not yet activated "PlatinumV3/V4" telemetry in panel 12.
Even though you are using the new Platinum 60A, you are still not seeing the RPMs in the new Recorded Logs. Have you connected the single yellow output lead of the ESC rotation pulses to the GOV port on the flight controller?
From the new Recorded Logs we see that now the "ServoVoltage" voltage feeding servos, flight controller and satellites is now much cleaner. This is probably mainly due to the new ESC.

Another issue is related to the rotation speed of the main rotor. It is well known that varying the rotational speed of the blades varies a great deal and the speeds at which the model reacts to the pilot's commands. For this reason it is necessary to try to keep the rotation speeds of the blades constant otherwise it becomes very difficult to fly the model.
Throttle output curves used to be used, which as the collective pitch increased (causing more strain on the motor and consequent slowing down), increased the throttle command (V- or U-shaped throttle curves).
With the advent of the Governors this is no longer necessary and the Governors are sent a straight and parallel and constant Throttle curve during stick movement that tells the Governor what rotational speed it should reach and maintain, then it is the Governor that controls the input RPM to keep it constant by varying the power delivered to the motor (as the read RPM drops, the power delivered to the motor increases and vice versa).
Then the Governors managed by the flight controllers took over, which, in addition to controlling the RPM signal is also informed of the collective pitch control and when the pitch is increased, it increases the power delivered by the motor even before the RPM starts to drop (the Governors of the flight controllers are called "Proactive" for this reason).
From the flight controller configuration you sent us it appears that the flight controller governor is not activated and from your recorded log graphs it is also visible that the Throttle curve is not constant to allow the ESC governor to operate but it is also not a V-shaped curve to operate without any Governor active because as the collective pitch increases instead of compensating for the increase in load by increasing the Throttle output signal it even behaves in reverse by decreasing the Throttle signal as the collective pitch and load on the motor increases and as the load decreases the power output increases:

immagine

As already explained, piloting a model in which the RPMs keep varying becomes very difficult because the response rates to the pilot's commands keep varying instead of remaining constant; in addition, the continuous variations in RPMs can generate unwanted and avoidable vibrations and resonances.

The various information about corrections you need to make in your model setup that, while not directly related to Auto Level, you still need to fix them all before you start using Auto Level.

In some Recorded Logs we see that from the moment the flight controller is turned on, Setup2 has Auto Level Active. This should absolutely never be done!
Every time the flight controller is turned on, the Auto Level auto tune must kick in, and the auto tune only works while the Auto Level is not controlling the model. Auto Level must absolutely be kept off from the time you power up the flight controller and until the model is already in flight.
This pilot usage error is indicated by 4 aileron swashplate movements at the end of initialization instead of the normal 4 vertical movements.
It is important for pilots at the end of initialization to check that the swashplate movements are normal.

Other key issues for the proper functioning of Auto Level (but also for the best possible flight), are:
- Correct balance of the model.
- Correct alignment of the flight control unit, which must be mounted on a surface perfectly orthogonal to the main shaft and never on a sloping surface.
- Adjusting the servo horns at 90° to the main shaft with collective and cyclic pitch at zero (best done in Wizard panel 8) and only then adjusting the lengths of the links from the swashplate servos going to the swashplate so that the swashplate is perfectly perpendicular to the main shaft.


   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1123
 

A check worth doing:
Upload the attached setup file to your flight controller (it will only change the first two parameters recorded in the logs).

Run bench tests by turning Setup2 on and off.
Send us the recorded log of this recording.
Thank you.


   
ReplyQuote
(@keith-joneses)
Active Member Customer
Joined: 9 months ago
Posts: 7
Topic starter  

@customercare Thanks for all the information, and all the errors i have in my setup and what to do to fix them. It's going to take some time to go through all your suggestions on fixing my setup issues.

I also have to admit, yes you are 100% correct in the fact that it's mainly a vibration issue, mostly from the high frequency harmonics and that's why the global vibrations are looking OK.  I took the unit out of the helicopter and laid it on the bench in the same orientation as when in it and things worked perfect, (the leads are long enough I could do that) no servo movement going in and out of Auto-Level.  Having the helicopter not fully assembled was part of that problem but not all.  After fully assembling it, and still getting servo movement, I found I could squeeze the sides of the frame by hand and servos did not move when switched in and out of Auto-Level.  I made and added a cross support between the frame halves, just under the main drive pully and used strips of foam tape inside the frame to help buffer high frequency harmonics and that stopped the servo movement when switching setups while on the bench.

I tried a test hover, and it made a couple of strange moves I didn't like and it was constantly wanting to go right when switched into Auto-Level, but I noticed every time it would start to spin up it gave that little body shake like they do when the blades are spinning out into position on the first spin up, but it was doing that on every spin up like it had a bent main shaft.  I had checked it before installing it and know it's straight, and I know the blades a perfectly balanced, so I've ordered a new Main Rotary Head for it.

Yes, I did install a new 2000mAH battery pack in the radio and four new 2200mAH 3S packs for the helicopters.

So, it will be a few days to get the new Head, and to go through all your suggestions and fixes to my setup, but hopefully my next post will say if fully cured.


   
BrainDev reacted
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1123
 

We suggest you still do what we had written to you:
https://www.msh-electronics.com/forum/postid/3140/

Regarding strange movements:
If any of the drops you've had with the new servos, check by moving them very slowly with the transmitter sticks that they don't make strange jumps otherwise a tooth of the servos' internal gears may have broken or deformed.


   
ReplyQuote
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.