Movimenti anomali d...
 
Notifications
Clear all

[Solved] Movimenti anomali del piatto durante l'accensione dell'unità brain v2

9 Posts
2 Users
0 Likes
57 Views
oransmandarino
(@oransmandarino)
Active Member Customer
Joined: 3 months ago
Posts: 5
Topic starter  

Buongiorno qualche giorno fa ho voluto provare il mio 470 align con la solita configurazione; pero' all'accensione il piatto non ha fatto i classici quattro movimenti durante il test iniziale, ma ben 17 (!!!) su e giu' ( se non ho sbagliato nel contarli...). dall'ultima volta che ho volato regolarmente non ho cambiato nulla, non ha mai preso colpi e roba del genere, ho provato a sostituire la batteria, quindi a spegnere la radio e riprovare ma quei movimenti li faceva sempre, per due o tre sequenze di accensione diverse.
Sono tornato a casa senza volare, ho connesso la centralina al pc con il programma msh ma non ho riscontrato nulla di anomalo, ho quindi effettuato un aggiornamento e ora pare funzionare tutto bene, ma posso fidarmi ?
Premetto che ho acceso e accendo sempre il modello in piano, che la centralina è saldamente incollata col biadesivo all'eli e che è settata correttamente la posizione di montaggio.

Allego il file events, il file di configurazione e le registrazioni di alcuni log.
In allegato inoltre un video in cui mostro la sequenza di accensione e i movimenti del piatto oscillante, il tutto è montato su un trex 470 pl.

Saluti,

Roberto.

 

video :

https://www.youtube.com/shorts/Z0Re-n-cUr0?cbrd=1

Eventi, configurazone e logs:

undefinedundefined

undefinedundefined

undefined


   
Quote
BrainDev
(@customercare)
Reputable Member Admin Registered
Joined: 4 years ago
Posts: 863
 

Ti era già stata data una spiegazione sul forum del Barone Rosso:

https://www.baronerosso.it/forum/5243585-post7150.html

Non è quindi chiaro cosa intendi dire ripetendo ancora “…. ma posso fidarmi?”.

Nella risposta alla domanda n°5 della sezione FAQ, è spiegato che la segnalazione mediante un elevato numero di movimenti del piatto è relativa ai soli valori letti dagli accelerometri e visto che gli accelerometri vengono usati solamente ed unicamente per le funzioni Auto Level e Rescue, ma che non vengono usati in alcun modo per il volo. Quindi quando c’è questa segnalazione, le due funzioni di Auto Level e Rescue vengono automaticamente disattivate fino alla prossima rialimentazione delal centralina ma il modello può volare senza alcun problema perchè per il volo vengono usati i giroscopi e non gli accelerometri. Di conseguenza, la risposta alla domanda è quella già presente nella risposta alla domanda n°5 ed è “ci si può fidare” a volare.

È poi anche spiegato che gli accelerometri a volte, anche se è molto raro, essendo sensori meccanici, possono bloccarsi a fine corsa e in questi rari casi per sbloccarli basta dare un colpetto con il manico plastico di un cacciavite alla centralina.

Gli accelerometri possono quindi anche essersi sbloccati se, durante l’inserimento del cavetto usb per l’aggiornamento del firmware e durante il disinserimento è stato dato un colpetto o uno strappetto alla centralina.

Vediamo che hai salvato il file di configurazione come spiegato nel messaggio e cioè mantenendo entrambi gli stick in basso e a destra. Notiamo però che in questo modo il passo collettivo risulta a +100% quando invece dovrebbe essere a -100%. Vediamo anche dal filmato che lo stick del gas della trasmittente è tutto in su. Usi forse lo stick del passo e del gas alla rovescia? In questo caso il reverse non deve essere fatto sul canale radio della trasmittente ma selezionando il Reverse corretto dei tre servi del pannello 8 del wizard. Altrimenti quando il Rescue si sostiuisce ai comandi del pilota e prende il controllo del passo aumentando il segnale del passo collettivo per far prendere quota al modello e allontanarlo da terra, farebbe il contrario perchè con valori positivi del passo darebbe passo negativo alle pale spingendo il modello verso terra.


   
ReplyQuote
oransmandarino
(@oransmandarino)
Active Member Customer
Joined: 3 months ago
Posts: 5
Topic starter  
Posted by: @customercare

Ti era già stata data una spiegazione sul forum del Barone Rosso:

https://www.baronerosso.it/forum/5243585-post7150.html

Non è quindi chiaro cosa intendi dire ripetendo ancora “…. ma posso fidarmi?”.

R: Chiedo scusa se ho postato il messaggio anche sul baronerosso, ho poi scoperto che esiste una sezione assistenza qui; con posso fidarmi intendevo dire se pur non presentando piu' l'anomalia, fosse sicuro volare ancora con questo problema.

Nella risposta alla domanda n°5 della sezione FAQ, è spiegato che la segnalazione mediante un elevato numero di movimenti del piatto è relativa ai soli valori letti dagli accelerometri e visto che gli accelerometri vengono usati solamente ed unicamente per le funzioni Auto Level e Rescue, ma che non vengono usati in alcun modo per il volo. Quindi quando c’è questa segnalazione, le due funzioni di Auto Level e Rescue vengono automaticamente disattivate fino alla prossima rialimentazione delal centralina ma il modello può volare senza alcun problema perchè per il volo vengono usati i giroscopi e non gli accelerometri. Di conseguenza, la risposta alla domanda è quella già presente nella risposta alla domanda n°5 ed è “ci si può fidare” a volare.

R: Va bene, grazie

È poi anche spiegato che gli accelerometri a volte, anche se è molto raro, essendo sensori meccanici, possono bloccarsi a fine corsa e in questi rari casi per sbloccarli basta dare un colpetto con il manico plastico di un cacciavite alla centralina.

Gli accelerometri possono quindi anche essersi sbloccati se, durante l’inserimento del cavetto usb per l’aggiornamento del firmware e durante il disinserimento è stato dato un colpetto o uno strappetto alla centralina.

R: Tutto chiaro ora.

Vediamo che hai salvato il file di configurazione come spiegato nel messaggio e cioè mantenendo entrambi gli stick in basso e a destra. Notiamo però che in questo modo il passo collettivo risulta a +100% quando invece dovrebbe essere a -100%. Vediamo anche dal filmato che lo stick del gas della trasmittente è tutto in su. Usi forse lo stick del passo e del gas alla rovescia? In questo caso il reverse non deve essere fatto sul canale radio della trasmittente ma selezionando il Reverse corretto dei tre servi del pannello 8 del wizard. Altrimenti quando il Rescue si sostiuisce ai comandi del pilota e prende il controllo del passo aumentando il segnale del passo collettivo per far prendere quota al modello e allontanarlo da terra, farebbe il contrario perchè con valori positivi del passo darebbe passo negativo alle pale spingendo il modello verso terra.

R: Si, uso lo stick del gas col minimo in alto. Dalla trasmittente non faccio nessun reverse del canale del gas; anche perche' al di la' della centralina, non funzionerebbe correttamente l'eli, ad esempio le curve del passo e del gas verrebbero visualizzate al contrario, e il trim del motore non funzionerebbe. Essendo abituato appunto col minimo in alto, e dato che questa mia attuale radio non permette il reverse del comando, ho smontato la stessa e invertito i due fili del potenziometro del gas, in questa maniera ottengo il reverse del comando senza modificare l'output , tanto è vero che l'autolevel e sopratutto il rescue, funzionano perfettamente.

Ho notato comunque che sul log degli eventi registrati, mi compare codice evento 161 tensione troppo alta; è un problema serio immagino visto che ho il pallino rosso, comunque ho riprogrammato il bec con una tensione piu' bassa, 6,5 volts; ho fatto bene ?

 

 


   
ReplyQuote
BrainDev
(@customercare)
Reputable Member Admin Registered
Joined: 4 years ago
Posts: 863
 
Posted by: @oransmandarino
 
Ho notato comunque che sul log degli eventi registrati, mi compare codice evento 161 tensione troppo alta; è un problema serio immagino visto che ho il pallino rosso, comunque ho riprogrammato il bec con una tensione piu' bassa, 6,5 volts; ho fatto bene ?

Si, hai fatto bene anche se invece di scendere fino a 6,5V bastave scendere fino a 7,5V (ovviamente serve che tutti e tre i servi del piatto e quello di coda siano tutti servi "HV").


   
ReplyQuote
oransmandarino
(@oransmandarino)
Active Member Customer
Joined: 3 months ago
Posts: 5
Topic starter  
Posted by: @customercare
Posted by: @oransmandarino
 
Ho notato comunque che sul log degli eventi registrati, mi compare codice evento 161 tensione troppo alta; è un problema serio immagino visto che ho il pallino rosso, comunque ho riprogrammato il bec con una tensione piu' bassa, 6,5 volts; ho fatto bene ?

Si, hai fatto bene anche se invece di scendere fino a 6,5V bastave scendere fino a 7,5V (ovviamente serve che tutti e tre i servi del piatto e quello di coda siano tutti servi "HV").

Purtroppo col mio attuale regolatore align RCE-BL50X Brushless, posso scegliere solo tre differenti voltaggi; 5 volts, 6,5 volts e 8,4 volts, senza nessuno step tra di loro.
All'inizio l'avevo regolato per una tensione di 8,4 volts, visto che sulla carta sia la centralina, che i servocomandi in dotazione reggono questa tensione, ma evidentemente la tensione stessa di targa del bec incorporato non è precisissima ed eccede gli 8,4 volts e attraverso il log eventi ce ne siamo resi conto.
Ho notato poi che la coda ora che ho diminuito la tensione di alimentazione, sbacchetta abbastanza vistosamente; ho provato ad abbassare il gain del giroscopio dalla radio, ma mi pare che cambi nulla o poco; prima era perfetto.

Provero' appena possibile di nuovo una tensione di 8,4 volts di bec, giusto per cercare di capire se lo sbacchettamento dipenda dalla tensione attuale troppo bassa, allego intanto nuovo log eventi con la tensione bec a 6,5 volts, l'allarme tensiona alta è sparito, pero' mi compare un nuovo allarme con pallino rosso "power voltage below 16 % than startup" in diversi momenti; cosa significa  ? E' Grave ?

 

 


   
ReplyQuote
BrainDev
(@customercare)
Reputable Member Admin Registered
Joined: 4 years ago
Posts: 863
 

L’evento n°102 "Power Voltage below 16,6% than startup" non è un messaggio rosso secondo il quale è sconsigliato volare ma è un messaggio arancio e quindi d’avvertimento che segnala che durante il test dell’alimentazione che viene effettuato durante i movimenti dello swashplate e di coda alla conclusione dell’inizializzazione della centralina volo, è stato riscontrato che quando i 4/5 servi si muovono assorbendo corrente, la tensione rispetto a quella misurata quando i servi sono fermi, cala di “almeno” il 16,6%.

Quando sono presenti questi eventi, bisognerebbe andare a vedere nel relativo Recorded Logs il grafico della tensione “Servo Voltage” e i relativi valori MAX e MIN per capire quanto sia grave il problema verificando se la tensione cala "solo" del 16% o se invece cala molto di più (in tal caso è vivamente sconsigliato volare perché con bassi valori di tensione d'alimentazione la ricevente potrebbe perdere il segnale e/o i servi fermarsi).

In qualsiasi regolatore elettronico è del tutto normale che la tensione d’uscita sia più stabilizzata quando la tensione d’uscita è più vicina alla tensione d’ingresso e viceversa meno stabile quando la differenza tra la tensione d’ingresso e la tensione d’uscita aumenta (il regolatore di tensione deve effettuare un maggior carico di lavoro a causa della maggior riduzione necessaria della tensione d'ingresso).

Per quanto riguarda il comportamento di coda con tensione d'alimentazione più bassa, ricordiamo che aumentando la tensione d'alimentazione dei servi (ma restando sempre all'interno dei valori nominali) la potenza e la velocità dei servi aumenta. Ci sono però molte marche di dervi "HV" che a 8,4V presentano problemi di funzionamento che spariscono alimentandoli a 7,5V.

Però se riducendo la tensione d'alimentazione del servo di coda aumentano i problemi vuol dire che il servo era già "al limite" delle prestazioni necessarie per il modello su cui è usato.

Si suggerisce di sganciare il rivio di coda dal servo e verificare che muovendo a mano il rinvio, non ci sia il minimo attrito. Altrimenti lubrificare, allineare e sistemare. E' infatti più probabile che riducendo la tensione d'alimentazione ci sia un problema di potenza troppo bassa, sopratutto quando il rotore di coda stà ruotando alla sua massima velocità e la forza centrifuga generata dalle pale di coda aumenta lo sforzo necessario piuttosto che un problema di velocità di risposta ridotta.


   
ReplyQuote
oransmandarino
(@oransmandarino)
Active Member Customer
Joined: 3 months ago
Posts: 5
Topic starter  

@customercare 
Buongiorno;
Ieri ho provato nuovamente il mio 470 pl, e purtroppo le oscillazioni in coda sono piuttosto evidenti; l'eli è relativamente nuovo, mai avuto crash, ho controllato il rinvio di coda e tutto scorre perfettamente. Ho anche voluto rifare una prova con la tensione a 8,4 volts, ma il problema persiste, anche se sembrerebbe con minore intensita'.
Ho visualizzato i log. registrati, e mi compare una oscillazione abbastanza marcata ma non continua alla voce "tail output %"; è l'ondeggiamento in coda che vedo ?
Allego i nuovi logs registrati e il file eventi.
I log registrati sono due, uno con tensione bec a 6,5 volts e uno a 8,4 volts.

P.s. In un vecchio thread su helifreak si parlava di bilanciare il rotore di coda in maniera da far lavorare il servo molto di meno, almeno da quel che si evince; che ne pensate ?
https://www.helifreak.com/showthread.php?t=41309

 


   
ReplyQuote
BrainDev
(@customercare)
Reputable Member Admin Registered
Joined: 4 years ago
Posts: 863
 

Stiamo sempre parlando del problema “Movimenti anomali del piatto durante l'accensione dell'unità brain v2” per cui è stato aperto questo thread oppure di tutt’altra questione?

In tal caso il presente thread avrebbe dovuto essere stato chiuso come risolto e aperto un nuovo thread per un problema del tutto diverso e differente.

Comunque sia: Si, le oscillazioni visibili nel segnale “Tail Out” dei Flight Logs è l’oscillazione del comando inviato al servo di coda per cercare di compensare le oscillazioni di coda.

È altrettanto chiaramente visibile che le oscillazioni del segnale Tail Out sono assenti fino a quando il segnale RX del Throttle non viene alzato (e quindi fino a quando il rotore non inizia a ruotare).

Pertanto, se le oscillazioni non sono causate dal guadagno “P” o al guadagno “I” troppo alti perché si è già provato ad abbassare i guadagni senza aver notato alcun beneficio, potrebbe essere un’oscillazione della coppia generata dal rotore principale a causa di un’oscillazione degli RPM che fa oscillare il comando di controcoppia dato al rotore di coda.

Purtroppo, il parametro degli RPM (undicesimo parametro) non risulta essere letto perché nei Flight Logs il valore è sempre a zero. Sarebbe stato utile che il segnale degli impulsi di rotazione inviati dall’ESC (se forniti dall’ESC) o inviati da un sensore di giri per motori elettrici fosse stato collegato alla porta d’ingresso GOV della centralina di volo. Senza questo segnale non è possibile verificare se gli RPM sono stabili oppure oscillano come ipotizzabile alla stessa frequenza con cui il servo di coda cerca di compensarli.

Se il problema fosse dovuto ad oscillazioni degli RPM bisognerebbe eliminarle intervenendo sulla configurazione del governor dell’ESC o, se non è possibile farlo, disattivando il governor dell’ESC ed attivando il governor della centralina di volo (ma in questo caso sarebbe assolutamente necessario avere il segnale degli RPM collegato alla porta GOV della centralina). Altrimenti se nessuna delle due precedenti soluzioni fosse possibile, allora bisognerebbe usare in coda un veloce servo di coda da 560Hz che grazie alla sua velocità sarebbe in grado di compensare anche veloci oscillazioni degli RPM del rotore principale.


   
ReplyQuote
oransmandarino
(@oransmandarino)
Active Member Customer
Joined: 3 months ago
Posts: 5
Topic starter  

Il problema sul topic iniziale è stato risolto; scusa se ho poi parlato di altro.
Apriro' un post nuovo poi

Thanks,
Roberto.

 


   
ReplyQuote
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.