Full cyclic at 50% ...
 
Notifications
Clear all

Full cyclic at 50% stick travel


tomas
(@tomas)
Active Member Customer
Joined: 1 week ago
Posts: 3
Topic starter  

Hello,

I have an issue where I get full 10 degree cyclic at 50% stick travel on the TX. The cyclic limit is correct - the remaining 50% of the stick does nothing.

Setup on page 5 is correct, when sticks for Ail and Ele are at 100% travel, I correctly see 100% in Brain setup.

In OpenTX I had to enable "Extended limits" to allow increasing limits past 100%, and "Enable max. throw" for the DSM protocol. After that, I could increase channel bottom and top points to achieve 100% in Brain setup.

Equipment:
- Brain 2
- SPM4651T
- OpenTX (TX16S)

To sumarize
- in OpenTX, enabled "Extended limits" and "Enable max. throw"
- in OpenTX, adjusted channel endpoints to see 100% in Brain setup page 5
- properly set servo endpoints in Brain setup page 8 to have 10 degrees of cyclic
- now when moving sticks on the TX, servos move to 10 degrees at 50% of stick travels

The collective is setup the exactly same way, and works correctly - properly travels to 12 degrees at 100% stick travel on the TX.

Any hints how to debug this?

Thanks!


Quote
BrainDev
(@customercare)
Member Admin
Joined: 3 years ago
Posts: 546
 

It is probably the first time you set up a flybarless model because this behavior is completely normal with flybarless controllers.
With the sticks of the transmitter you don't directly control the servos but you tell the flybarless control units at what speed you want the model to rotate on one of the rotation axes X, Y, Z.
Then the gyros of the control unit, after processing the data in the CCPM mixer, send commands to the servos to try to reach the rotation speed requested by the pilot.
If the model is stationary on the workbench, the gyros do not read the required rotation speed and increase the command sent to the servos to try to increase the rotation speed of the model.
It is therefore normal that when the model is stationary on the workbench, the maximum tilt of the swashplate and the blades is reached even with a reduced stick movement.
In flight the model is free to rotate and the behavior is different.

Also regarding the "Extended Limits" checkboxes, this is completely normal.
All OpenTX users have to select these checkboxes in order to have the possibility to adjust the limits as it is done by default for all other brands of radios.


ReplyQuote
tomas
(@tomas)
Active Member Customer
Joined: 1 week ago
Posts: 3
Topic starter  

Thanks for the info - this is indeed my first time setting up an FBL unit. Happy to hear that this is expected behavior, this was the only "issue" I had during setup.


BrainDev liked
ReplyQuote
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.