Wierd governor beha...
 
Notifications
Clear all

[Solved] Wierd governor behaviour


michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 1 year ago
Posts: 10
Topic starter  

 

Hello,

Used hardware:

- BRAIN2 with firmware version 3.4.000 (not latest because of issue with link live)

- Castle creation Phoenix EDGEHV 80 (set to external governormode)

- FRSKY ARCHER RS connected using F-BUS

attached a backup of the config.

Issue:

1) As soon as i set the throttle output to 40% it takes about 6 seconds before the head starts spining.

2) The RPM is first exceeding the desired head speed, then it dropt to the desired speed. In my example the head speed should be 1800, but it went up to 2300. See logging:

any ideas what is causing this?

 

image

BrainDev
(@customercare)
Member Admin
Joined: 4 years ago
Posts: 780
 

The problem of point 1, is completely normal since as explained in the instructions, the Out MIN value for ESC Castle Creation should be set to 1046uS, but you have set it to 946uS. It takes longer for the soft start Ramp Up of the Flight Control Unit to Ramp Up from 946uS to 1940us and then begin to Ramp Up to start the motor.

immagine

Also the problem of point 2, is completely normal because a) by creating a throttle out travel from 946uS to 1046uS you have reduced the resolution of the valid part of the Thrttle Out curve, b) Furthermore, in the ESC configuration, in addition to the soft start of the flight control unit, you have added a further slowdown by setting the value of the "Initial Spool Up Rate" to 2 instead of the default value of 5, this makes the increase of the Throttle Out of the governor of the flight control unit continue, since the motor is slowed down by the "Initial Spool Up Rate" of the ESC. By the time the ESC finishes its spool up, the throttle of the governor is already too high. It would be better to leave the default values or even better to use the "Airplane mode" (not ESC spool up which will add up and conflict with the governor spool up of the Flight Control Unit).

immagine

michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 1 year ago
Posts: 10
Topic starter  

Hello, Thanks for the quick answer!

After changing the spool-up setting, the RPM issue was solved! all makes sense.

But then issue 2 was still there, tried the suggested value of 1046, but then the ESC would not arm anymore. Lowered it to 996, then arming was working again. but spool-up was 6 seconds..

I changed the mode of the ESC from "external Governor" to "Heli" and to "airplane". In Heli and airplane mode, the ESC started arming at the 1046. But still it took 6 seconds before initial spool-up started....

Then i decided to factory reset the ESC, and reconfigered it using the previous External governor settings. Now the ESC arms at the 1048 value, and the spool-up starts after 1 ~2 seconds!

SO, it seams that the ESC was causing this for whatever reason!.

As mentioned before, Thanks for the help!


BrainDev liked
BrainDev
(@customercare)
Member Admin
Joined: 4 years ago
Posts: 780
 

Great!
In this case, it means that you have (intentionally or unintentionally) reprogrammed the MIN/MAX values of the throttle of your ESC, which, as you know, is done by turning on the ESC with the throttle at maximum and then setting the throttle to minimum.


Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.