Governed Headspeed ...
 
Notifications
Clear all

Governed Headspeed drop


Ahmad KASSEM
(@ak2200)
Active Member Customer
Joined: 5 months ago
Posts: 5
Topic starter  

Dear Sir

 

From the attached log you can notice that the governed headspeed has dropped from 2400 to 2000 rpm without me changing anything, the RxThrottle was still the same, I also spooled down and spooled up again but the rpm still at 2000rpm,I was on setup 3 all the time with governor engaged and speed 3 2450rpm activated.

Kindly explain why this is happening

 

Best Regards

Ahmad

 


Quote
BrainDev
(@customercare)
Member Admin
Joined: 3 years ago
Posts: 638
 

Have you read note 1 on page 2 of the Telemetry document in the MANUALS section of the software?
The "OPTO" versions of the HobbyWing ESCs require the HobbyWing accessory coded "30850200", otherwise the telemetry signals coming out of the OPTO ESCs will be weak and noisy and as a result the control unit may receive incorrect information.

The automatic 20% RPM reduction is normal and is expected when using the "Max mAh Usable" function that you activated by setting it to 3.300mAh.
In the Fligh Log you sent, the 20% reduction (from ~2400 to ~1920) occurs 7.88 minutes after you started the motor and this is normal even though it seems like a very long time to discharge only 3,300mAh from the main battery.

If you recharged the battery with the charger and saw that you recharged less (or more) than 3.300mA, then you can correct the battery discharge value using the "mAh Correction Factor %" parameter because due to the tolerances of the components in each ESC the measurements may differ from one ESC to another.
If the mAh value discharged from the battery is very far from the recharged value, it could be due to the lack of HobbyWing accessory "30850200" and signal noise.

As an aside, we have noticed:

1) You have not activated the governor in Setup1. Beware that in this way the soft start of the Brain2 governor is deactivated and the blades might start suddenly, rotate on the blade clamps and bend downwards hitting the tail boom.

2) You have set the MIN value of the Throttle output signal to 1500us. This is a very, very high value that reduces the accuracy of the ESC control by the Governor of the ECU. You have probably reprogrammed your ESC incorrectly. We suggest that you reset your ESC to factory settings and set the MIN value of the throttle output signal to the factory value listed in the instructions for all HobbyWing ESCs of 1100us.

3) In the vibration graph you have very high vibration only in the main rotor. So we suggest you to check the tracking of the main blades and their balance in order to extend the average life of your model.

4) In Events there are several "Rudder output limit reached" events, which means that the tail output limit has reached the maximum value beyond which it cannot go because the rotor thrust is not sufficient for the required thrust. To increase the thrust of the tail rotor, you need to increase the rotation speed of the tail rotor by using a tail pulley with fewer teeth, or mount more efficient tail blades (wide and/or long) making sure, if you use longer tail blades, that they cannot touch the main blades when the main rotor flaps backwards during fast and violent maneuvers.


ReplyQuote
Ahmad KASSEM
(@ak2200)
Active Member Customer
Joined: 5 months ago
Posts: 5
Topic starter  

thank you for your swift reply, i have corrected the problems as you have instructed.

 

regarding the last point, i checked the tail rotor ratio by using a tachometer and confirm that the ration is 3.85 as per the manual also i checked the tail blade length and it is 95mm as per the manual, by the way my heli is Trex 600.

is there something else i need to check to solve the "Rudder output limit reached" event?

 

Regards

Ahmad


ReplyQuote
BrainDev
(@customercare)
Member Admin
Joined: 3 years ago
Posts: 638
 

The first thing to check, even though it should already be in place, is the tail linkage travel limits, which should already be maxed out on both sides (but without going over the top and risking the tail servo overheating).

The other thing is to increase the tail ratio. Unfortunately, most Align models have a low tail ratio and in fact 3.84 is low. In the tail (unless you always use very high rotor RPMs to fly) you need ratios higher than 4.
You should therefore look (as we have already told you) for a kit to increase the tail ratio, which usually with belt drives simply consists of a tail pulley with fewer teeth.

Alternatively, try fitting 100mm or 105mm tail blades (with the care already mentioned above).


ReplyQuote
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.