Brain2 does not con...
 
Notifications
Clear all

[Closed] Brain2 does not connect at SAT1 or SAT2

3 Posts
2 Users
0 Reactions
103 Views
(@kouvalakidis_andreas)
New Member Customer
Joined: 5 months ago
Posts: 1
Topic starter  

Latest versions at Brain2. DSM2 satellite. I select the DSM2 1024/22ms, 7ch on Brain App. I am able to bind, but after this no transmitter input at brain app. The status bar (in app) of the SAT1 is always red. Transmitter is multiprotocol with EdgeTX.

What could possibly gone wrong?


   
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1118
 

Can you read and do as indicated in the sticky post:
https://www.msh-electronics.com/forum/support/when-you-ask-for-support/#post-1739 ?
Thank you!
Are these original Spektrum satellites?
Have you tried binding in DSM2 2048/11ms mode yet?
What brand and model of transmitter are you using?
What version of EDGE are you using?
Have you updated both your transmitter and multimodule firmware to the latest version available?
Is the configuration you have set up as follows?

immagine

   
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1118
 

The user never answered the questions.
The user did not have the courtesy to say whether he has since solved his problem.
Likely he did not answer because he has resolved it.
By not explaining why he had the reported problem and how he solved it, this post is not helpful to anyone.
Therefore, after three months of waiting for a response, we are closing the post.


   
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.