Hobbywing ESC start...
 
Notifications
Clear all

Hobbywing ESC start up issues

2 Posts
2 Users
0 Likes
283 Views
(@kimberlyhillsoil)
Member
Joined: 2 years ago
Posts: 4
Topic starter  

Align 500xt. stock servos and align BL80A (previously futaba s bus )360 flights never crashed.

during these 360 flights probably 5 times the start up has spooled the blades around nice and slow for the first few turns then it goes crazy flat out and turns the heli on its skids a bit, so long as you were zero pitch it was no great shakes just woke you up a little. I recently changed to Jeti, and changed the esc out for a hobbywing 120a, due to the spool up issue.

throttle connected to receiver directly.

I set store gov and initialised the first flight 0 degrees, all good. first few flights perfect. slow spool up nice, i have 5/6 of these hobbywing esc, but this heli on the 3rd spool up turned the blades maybe 3 times then just went full bore, killed itself on the spot, probably turn 5/6 was the boom strike, it blew the gears one way bearing all the blades, swashplate, big mess my only difference was i had enabled telemetry.......which was working...(no auto bailout set as its a 500) Any ideas? Much as welcomed as its shelved till someone can Help Solve the mystery..


   
Quote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1106
 

Please, for an answer, first read the sticky post "IF YOU ARE ASKING FOR SUPPORT..."

https://www.msh-electronics.com/forum/general-discussions/if-you-are-asking-for-support/#post-2210

Thanks


   
ReplyQuote
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.