Brain2 with Phoenix...
 
Notifications
Clear all

Brain2 with Phoenix Edge telemetry wierd RPM changes


michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 6 months ago
Posts: 6
Topic starter  

 

Hello,

I have a Brain2 and a Castle Phoenix EDGE 80 HV ESC

When i connect the Castle Phoenix Edge directly to the brain2, and i leave all telemetry to default all works fine. As soon as i throttle up, the motor start spinning. (i have a simple throttle curve, no governor modes etc)

Then i added the resistor of 10K between the red and Yellow wire, and i enabled in the ESC the option " Link Live Enabled" and set the "auxiliary wire mode" to "RPN out" (not sure why this is is needed, bacause the wire is not connected)

In the Brain2 i changed the telemetry input to also capture the Phoenix edge data.

As soon as i turn on everything i get new telemetry sensors in my transmitter! that seams to be OK, the values are updates etc.

Now the issue:

As soon as i throttle up, the motor start spinning, but it is continuously changing the RPM enormous. See the video.

When i turn of the Link live in the ESC, and i turn of the extra telemetry in the brain2, all is fine again, even with the resistor still in place. But i do not get any telemetry data anymore...

What can i do to solve this?

attached the config of my Brain2

The brain2 is connected to an Archer RS receiver over the FBUS

 


Quote
michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 6 months ago
Posts: 6
Topic starter  

the video


ReplyQuote
michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 6 months ago
Posts: 6
Topic starter  

Hello, is there already an idea what could cause this rpm change?


ReplyQuote
BrainDev
(@customercare)
Member Admin
Joined: 3 years ago
Posts: 672
 
Posted by: @michel-korthouticloud-com

Hello, is there already an idea what could cause this rpm change?

Can you please try if manually loading firmware 3.4.000 solves the problem and let us know?
Thank you.


ReplyQuote
michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 6 months ago
Posts: 6
Topic starter  

Hello,

Just downgraded the Brain2 to version 3.4.000 and did a quick test. Now all seams to be stable! a nice constant RPM.

The problem is not there when using this older version


ReplyQuote
BrainDev
(@customercare)
Member Admin
Joined: 3 years ago
Posts: 672
 
Posted by: @michel-korthouticloud-com

Hello,

Just downgraded the Brain2 to version 3.4.000 and did a quick test. Now all seams to be stable! a nice constant RPM.

The problem is not there when using this older version

Fine
Now you are able to fly with this firmware.
In the meantime we will look for a solution to make sure that in future firmware releases your problem will not occur again.


ReplyQuote
michel.korthout@icloud.com
(@michel-korthouticloud-com)
Active Member Customer
Joined: 6 months ago
Posts: 6
Topic starter  

Thanks, if I need to do some testing with a new release, let me know


ReplyQuote
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.