Brain2 Integration
 
Notifications
Clear all

Brain2 Integration

17 Posts
2 Users
1 Likes
551 Views
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

My TX16s Max MKII has latest EdgeTX 2.7.1, when i go into the integration im seeing all screen apart from the B2 thrott/gov which is only partially loading, thought I'd ask here before going to ETX, all pages load quick but gov page stops short of loading. 


   
Quote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  
IMG 20220915 093546
IMG 20220915 093612

   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1106
 

Thank you for the report.
Since we have seen during development that some parameters are not transferred by some receiver models and we have had to use conversions in the flight controller firmware and reconversions in the LUA app depending on the type of receiver, we need to know which receiver you are using and which firmware version you are using in the receiver.
We would also need to know which of the many protocols you are using: the Smart.Port+S.Bus protocol, or the F.Port protocol or the F.Port2 protocol or the F.Bus protocol?
Can you also confirm to us that your TX16S transmitter is a RadioMaster?
Thank you


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

@customercare RadioMaster TX16s Max MKII has latest EdgeTX 2.7.1, RadioMasterReceiver R161,

IMG 20220915 154643
IMG 20220915 160302
Untitled

 


   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1106
 

Unfortunately, we do not have the RadioMaster R161 receiver available.
We have asked our distributors if they have one to send us but no one has it available.
So we have to look for it, order it, wait for it to reach us, and start testing to fix the problem.
We expect to be able to introduce the fix in the next Firmware, Software (Windows, Andorid, iOS), and LUA app release that we plan to release by the end of this month.


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

@customercare Really appreciate this, thank you.


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

@customercare Have we had any luck getting your hands on the R161 receiver.


   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1106
 

Being able to find R161 receivers on the market and have them shipped to us has become impossible.
They are no longer available.
However, we had purposely introduced in the latest version of the LUA app and new firmware's a modification for a different method of loading the Speed2 parameter.
Have you tried the latest version of the LUA app with the latest firmware?


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

@customercare Aww no I haven't I'll go and try it now.


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

No luck, done latest firmware and integration lua app, may have to go over to the Frsky R-XSR

screen 2023 01 11 154746
screen 2023 01 11 154631
screen 2023 01 11 154738
screen 2023 01 11 154805

 


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

That's interesting, I've just swapped back to Frsky S XSR (ACCST 2.1.1 firmware version "RXSR_ACCST_2.1.1_Fport" into the R-XSR receiver and connect S.Port output to the CH3 of the flight controller then selected F.Port inverted protocol tab) and still don't have the completed 6/14 page as above pic shows, so I'm now guessing it's not the receivers, BrainDev would you have any suggestion to this please, I'm on latest 3.4.103 firmware and V20 integration, Radiomaster TX16s Mll, EdgeTX 2.8.1 (Bind FrSkyX2) - LBT(EU)


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

Also after the above setup, Binding S XSR has strong signal but telemetry & integration is very slow to load and drops out intermittently, this never happened when I last used FrSky S XSR 2020/21, I've tried two receivers same things happening with both.


   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1106
 

As is well known, the multiprotocol radio modules of RadioMaster transmitters do not work with the ACCESS protocol but only with the ACCST protocol.
We unfortunately found out only in retrospect a few months ago that FrSky receivers if they have been upgraded with ACCESS firmware with F.Port (and we had upgraded all of them), it is then no longer possible to revert them back to ACCST mode with F.Port by loading the old ACCST Firmware.
The only receiver that we have never upgraded with ACCESS firmware is the X8R because no ACCESS firmware has ever been released for this receiver (but neither has a firmware that works in F.Port mode).
Using our RadioMaster TX16S transmitter with the latest version of EdgeTX 2.8.1 and the X8R receiver connected to a Brain2 control unit in Smart.Port + S.Bus mode, version 20 of our LUA Integration app runs smoothly and without any blockages causing the parameter loading progress bar to freeze on page 6 nor on any other page.

immagine

   
ReplyQuote
(@customercare)
Reputable Member Admin Registered
Joined: 6 years ago
Posts: 1106
 

To try to analyze your problem, since two R-XSR receivers that we had both upgraded to ACCESS, no longer load the previous ACCST firmware with F.Port protocol, we purchased a third R-XSR receiver that is manufactured and supplied with ACCST firmware and arrived today.

We loaded the firmware "RXSR_ACCST_2.1.1_Fport_LBT.frk" into it.

We connected it to a Brain2 controller with firmware 3.4.103 and binded it to our RadioMaster TX16S transmitter with S.O. EdgeTX v2.8.1 and MULTI internal module with firmware V1.3.3.20 AETR, using FrSkyX2 mode and LBT(EU) RF protocol.

All pages and all parameters in the LUA 20 app load. Even all those on page 6 (Thrott.&Gov).

In fact, the parameters load quite slowly.

Even with a totally different transmitter, the FrSky Taranis X9D Plus SE 2019 (binded in D16 mode) which uses a different S.O. (OpenTX) all parameters load and as fast as they load with the TX16S.

So, if you are using the same firmware as the receiver, MULTI module, and Brain2 and the same version of EdgeTX and you have the problem that the LUA app crashes when loading the "speed 2" parameter on page 6, then it can only depend on your transmitter since the rest is identical.

Instead, the low loading speed probably depends on the R-SXR receiver and its firmware since the behavior is the same changing both the operating system (EdgeTX => OpenTX) and the transmitter (TX16S => Taranis X9D).

You should then report the problem with your transmitter model to RadioMaster and EdgeTX. Problem not present on RadioMaster TX16S.


   
ReplyQuote
(@jimm-y)
Trusted Member Customer
Joined: 3 years ago
Posts: 55
Topic starter  

@customercare

I got new R XSR unopened in packet so I'll give that a go ? 


   
ReplyQuote
Page 1 / 2
Join Waitlist We will inform you when the product arrives in stock. Just leave your valid email address below.
Email Quantity We won't share your address with anybody else.